Apache mod_python < 2.7.8 Imported Function Access

High Nessus Network Monitor Plugin ID 1511

Synopsis

The remote server is running a web server that is affected by a vulnerability

Description

The remote Apache server is running a version of mod_python which is older than 2.7.6. This version contains a bug which may allow an attacker to execute potentially harmful python function even though he should not have the privileges to do so.

Solution

Upgrade to mod_python 2.7.8 or higher.

See Also

http://www.modpython.org/pipermail/mod_python/2002-April/012512.html

http://lwn.net/alerts/Conectiva/CLA-2002:477.php3

Plugin Details

Severity: High

ID: 1511

File Name: 1511.prm

Family: Web Servers

Published: 2004/08/18

Modified: 2016/01/15

Dependencies: 3057

Nessus ID: 10947

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Reference Information

CVE: CVE-2002-0185

BID: 4656