Apache mod_auth_mysql < 1.10 SQL Injection

High Nessus Network Monitor Plugin ID 1492

Synopsis

The remote server is running a web server that is affected by a vulnerability

Description

The remote host is running a version of mod_auth_mysql which is older than 1.10. It is vulnerable to a SQL injection attack which may let anyone bypass authentication or even modify your database.

Solution

Upgrade to mod_auth_pg 1.10 or higher.

See Also

http://archives.neohapsis.com/archives/vulnwatch/2001-q3/0040.html

Plugin Details

Severity: High

ID: 1492

Family: Web Servers

Published: 2004/08/20

Modified: 2016/01/15

Dependencies: 3057

Nessus ID: 10752

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Reference Information

CVE: CVE-2001-1379

BID: 3251, 3253