PHP < 4.1.2 POST Request file_upload Overflow

High Nessus Network Monitor Plugin ID 1485

Synopsis

The remote host is running a version of PHP which is older than 4.1.2.

Description

The remote host is running a version of PHP which is older than 4.1.2. This version contains a bug which the handling functions of data of type multipart/form-data, which may allow an attacker to gain a shell on this host.

Solution

Upgrade to PHP 4.1.2 or higher.

See Also

http://php.net/ChangeLog-4.php

Plugin Details

Severity: High

ID: 1485

File Name: 1485.prm

Family: Web Servers

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 8728

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2003/03/26

Vulnerability Publication Date: 2001/02/27

Exploitable With

Core Impact

Reference Information

CVE: CVE-2002-0081

BID: 4183