PHP < 4.3.2 Multiple Function Remote Overflows

Medium Nessus Network Monitor Plugin ID 1484

Synopsis

The remote host is running a version of PHP which is older than 4.3.2.

Description

The remote host is running a version of PHP which is older than 4.3.2. This version contains various flaws that may allow an attacker who has the ability to execute PHP scripts in safe_mode on this host to execute arbitrary commands with the privileges of the HTTP daemon.

Solution

Upgrade to PHP 4.3.2 or higher.

See Also

http://php.net/ChangeLog-4.php

Plugin Details

Severity: Medium

ID: 1484

Family: Web Servers

Published: 2004/08/20

Modified: 2016/02/05

Dependencies: 8728

Nessus ID: 11468

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

CVSSv3

Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2003/03/26

Vulnerability Publication Date: 2003/03/26

Reference Information

CVE: CVE-2003-0166, CVE-2003-0172

BID: 7256, 7259, 7187, 7197, 7198, 7199, 7210