PHP < 4.0.4 php.cgi Shell Access Overflow

High Nessus Network Monitor Plugin ID 1482


The remote web server uses a version of PHP that is affected by a buffer overflow vulnerability.


The PHP CGI program 'php.cgi' is vulnerable to a buffer overflow. A remote attacker can overflow the buffer and execute arbitrary code on the system under the UID of the user owning the httpd process, usually "nobody." An attacker could exploit this vulnerability to change to contents of a Web page or gain root or administrator access to the system.


Upgrade to version 4.0.4 or higher.

See Also

Plugin Details

Severity: High

ID: 1482

Family: Web Servers

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 8728

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.4


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 1997/04/17

Vulnerability Publication Date: 1997/04/17

Reference Information

CVE: CVE-1999-0058

BID: 712