PHP 3.0.x < 3.0.17 / 4.0.x < 4.0.3 Error Log Command Injection

Medium Nessus Network Monitor Plugin ID 1480

Synopsis

The remote host is running a version of PHP which is older than 3.0.17 or 4.0.3.

Description

The remote host is running a version of PHP which is older than 3.0.17 or 4.0.3. If the option 'log_errors' is set to 'On' in php.ini, an attacker may use a bug present in this version to execute arbitrary commands on this host.

Solution

Upgrade your installation of PHP to 3.0.17 or 4.0.3 or higher.

See Also

http://php.net/ChangeLog-4.php

Plugin Details

Severity: Medium

ID: 1480

Family: Web Servers

Published: 2004/08/20

Modified: 2016/01/19

Dependencies: 8728

Nessus ID: 10535

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2000/10/14

Vulnerability Publication Date: 2000/10/14

Reference Information

CVE: CVE-2000-0967

BID: 1786