PHP < 4.0.4 IMAP Module Overflow

Medium Nessus Network Monitor Plugin ID 1479

Synopsis

The remote host is running a version of PHP which is older than 4.0.4.

Description

The remote host is running a version of PHP which is older than 4.0.4. There is a buffer overflow in the IMAP module of this version which may allow an attacker to execute arbitrary commands with the privileges of the web server if a PHP script connects to a rogue IMAP server.

Solution

Upgrade to PHP 4.0.4

See Also

http://php.net/ChangeLog-4.php

http://seclists.org/bugtraq/2001/Mar/0040.html

http://online.securityfocus.com/archive/1/166602

Plugin Details

Severity: Medium

ID: 1479

Family: Web Servers

Published: 2001/03/08

Modified: 2016/01/19

Dependencies: 8728

Nessus ID: 10628

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2000/12/19

Vulnerability Publication Date: 2000/12/19

Reference Information

BID: 6557