PHP < 4.2.2 Malformed POST Requests

High Nessus Network Monitor Plugin ID 1476

Synopsis

The remote host is running a version of PHP which is older than 4.2.2.

Description

The remote host is running a version of PHP which is older than 4.2.2. This version has a bug which allows an attacker to disable the remote server or execute arbitrary code on it.

Solution

Upgrade to PHP 4.2.2 or downgrade to 4.1.x

See Also

http://php.net/ChangeLog-4.php

Plugin Details

Severity: High

ID: 1476

Family: Web Servers

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 8728

Nessus ID: 11050

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2003/09/09

Vulnerability Publication Date: 2003/09/09

Reference Information

CVE: CVE-2002-0986

BID: 5562, 5278