WebLogic Server < 5.1 SP 7 ".." URL Handling Remote Overflow DoS

Critical Nessus Network Monitor Plugin ID 1454

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote WebLogic server can be disabled remotely by requesting a long URL starting with a double dot.

Solution

Upgrade to WebLogic 5.1 SP7 or higher

See Also

http://archives.neohapsis.com/archives/bugtraq/2000-12/0331.html

Plugin Details

Severity: Critical

ID: 1454

File Name: 1454.prm

Family: Web Servers

Published: 2004/08/20

Modified: 2016/01/19

Dependencies: 1442

Nessus ID: 10697

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:bea:weblogic_server

Reference Information

CVE: CVE-2001-0098

BID: 2138