Apache-SSL < 1.3.29 / 1.53 SSLVerifyClient SSLFakeBasicAuth Client Certificate Forgery

High Nessus Network Monitor Plugin ID 1167

Synopsis

The remote server is configured to allow a potential bypass of authorization.

Description

The remote host is running a version of Apache-SSL which is older than 1.3.29/1.53. This version is vulnerable to a flaw which may allow an attacker to make the remote server forge a client certificate.

Solution

Upgrade to version Apache-SSL 1.3.29/1.53 or later.

See Also

http://archives.neohapsis.com/archives/fulldisclosure/2004-02/0257.html

http://www.apache-ssl.org/advisory-20040206.txt

http://www.apache-ssl.org

Plugin Details

Severity: High

ID: 1167

Family: Web Servers

Published: 2004/08/20

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 12046

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:apache-ssl

Reference Information

CVE: CVE-2004-0009

BID: 9590