Atlassian Confluence 6.0.x < 6.0.7 Drafts diff REST Information Disclosure

Medium Nessus Plugin ID 99986

Synopsis

A web application running on the remote host is affected by an information disclosure vulnerability.

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is 6.0.x prior to 6.0.7. It is, therefore, affected by an information disclosure vulnerability in the Confluence drafts diff REST resource due to making available the page IDs or draft IDs without requiring authentication. A remote attacker with access to the Confluence web interface can exploit this, by enumerating the IDs, to disclose the potentially sensitive contents of all blogs and pages in Confluence.
Furthermore, if anonymous access has been enabled, a valid user account is not required to exploit this vulnerability.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Confluence version 6.0.7 or later, or apply the appropriate vendor patch.

See Also

http://www.nessus.org/u?21bcd1e2

https://jira.atlassian.com/browse/CONFSERVER-52222

Plugin Details

Severity: Medium

ID: 99986

File Name: confluence_6_0_7.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2017/05/05

Updated: 2018/06/14

Dependencies: 53574

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: www/confluence, Settings/ParanoidReport

Patch Publication Date: 2017/04/19

Vulnerability Publication Date: 2017/04/19

Reference Information

CVE: CVE-2017-7415

BID: 97961