Jenkins < 2.46.2 / 2.57 and Jenkins Enterprise < 1.625.24.1 / 1.651.24.1 / / Multiple Vulnerabilities

Critical Nessus Plugin ID 99984


A job scheduling and management system hosted on the remote web server is affected by multiple vulnerabilities.


The version of Jenkins running on the remote web server is prior to 2.57 or is a version of Jenkins LTS prior to 2.46.2, or else it is a version of Jenkins Enterprise that is 1.625.x.y prior to 1.625.24.1, 1.651.x.y prior to 1.651.24.1, 2.7.x.0.y prior to, or 2.x.y.z prior to It is, therefore, affected by multiple vulnerabilities :

- A remote code execution vulnerability exists within core/src/main/java/jenkins/model/ that allows an untrusted serialized Java SignedObject to be transfered to the remoting-based Jenkins CLI and deserialized using a new ObjectInputStream. By using a specially crafted request, an unauthenticated, remote attacker can exploit this issue to bypass existing blacklist protection mechanisms and execute arbitrary code. (CVE-2017-1000353)

- A flaw exists in the remoting-based CLI, specifically in the class, when storing the encrypted username of a successfully authenticated user in a cache file that is used to authenticate further commands. An authenticated, remote attacker who has sufficient permissions to create secrets in Jenkins and download their encrypted values can exploit this issue to impersonate any other Jenkins user on the same instance. (CVE-2017-1000354)

- A denial of service vulnerability exists in the XStream library. An authenticated, remote attacker who has sufficient permissions, such as creating or configuring items, views or jobs, can exploit this to crash the Java process by using specially crafted XML content.

- Cross-site request forgery (XSRF) vulnerabilities exist within multiple Java classes due to a failure to require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. An unauthenticated, remote attacker can exploit these to perform several administrative actions by convincing a user into opening a specially crafted web page.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade Jenkins to version 2.57 or later, Jenkins LTS to version 2.46.2 or later, or Jenkins Enterprise to version 1.625.24.1 / 1.651.24.1 / / or later.

See Also

Plugin Details

Severity: Critical

ID: 99984

File Name: jenkins_2_57.nasl

Version: $Revision: 1.4 $

Type: remote

Family: CGI abuses

Published: 2017/05/04

Modified: 2018/02/20

Dependencies: 65054

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND


Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins

Required KB Items: www/Jenkins

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/04/26

Vulnerability Publication Date: 2017/04/13

Reference Information

CVE: CVE-2017-1000353, CVE-2017-1000354, CVE-2017-1000355, CVE-2017-1000356

BID: 98056, 98062, 98065, 98066

OSVDB: 154967, 156516, 156517, 156518, 156519, 156531, 156532, 156533, 156534, 156535, 156536, 156537, 156538, 156539, 156540, 156541, 156542, 156543, 156544, 156545, 156546, 156547, 156548, 156549, 156550, 156551, 156552, 156553, 156554, 156555, 156556, 156557, 156558, 156559, 156560, 156561