EulerOS 2.0 SP1 : sudo (EulerOS-SA-2017-1004)

Medium Nessus Plugin ID 99851


The remote EulerOS host is missing multiple security updates.


According to the versions of the sudo package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities :

- It was discovered that the sudo noexec restriction could have been bypassed if application run via sudo executed system(), popen(), or wordexp() C library functions with a user-supplied argument. A local user permitted to run such application via sudo with noexec restriction could use these flaws to execute arbitrary commands with elevated privileges. (CVE-2016-7032, CVE-2016-7076)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected sudo packages.

See Also

Plugin Details

Severity: Medium

ID: 99851

File Name: EulerOS_SA-2017-1004.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2017/05/01

Modified: 2018/01/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Temporal Score: 5.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7

Temporal Score: 6.4

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:sudo, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/01/07

Reference Information

CVE: CVE-2016-7032, CVE-2016-7076

OSVDB: 146413, 146414