EulerOS 2.0 SP1 : cyrus-imapd (EulerOS-SA-2016-1040)

High Nessus Plugin ID 99803


The remote EulerOS host is missing multiple security updates.


According to the versions of the cyrus-imapd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities :

- The cyrus-imapd package contains the core of the Cyrus IMAP server. It is a scaleable enterprise mail system designed for use from small to large enterprise environments using standards-based internet mail technologies.

- Security Fix(es)

- The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.(CVE-2015-8076)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected cyrus-imapd packages.

See Also

Plugin Details

Severity: High

ID: 99803

File Name: EulerOS_SA-2016-1040.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2017/05/02

Modified: 2017/05/02

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:cyrus-imapd, p-cpe:/a:huawei:euleros:cyrus-imapd-utils, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/08/31

Reference Information

CVE: CVE-2015-8076

OSVDB: 128212