VMware Horizon View 6.x < 6.2.4 / 7.x < 7.1.0 Unspecified Buffer Overflow RCE (VMSA-2017-0008)

Critical Nessus Plugin ID 99708


A virtualization application installed on the remote Windows host is affected by a remote code execution vulnerability.


The version of VMware Horizon View installed on the remote Windows host is 6.x prior to 6.2.4 or 7.x prior to 7.1.0. It is, therefore, affected by an unspecified heap buffer overflow condition that allows an unauthenticated, remote attacker to execute arbitrary code.


Upgrade to VMware Horizon View version 6.2.4 / 7.1.0 or later.

See Also


Plugin Details

Severity: Critical

ID: 99708

File Name: vmware_horizon_view_VMSA-2017-0008.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2017/04/27

Modified: 2017/08/16

Dependencies: 76944

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:horizon_view

Required KB Items: installed_sw/VMware Horizon View

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/04/18

Vulnerability Publication Date: 2017/04/18

Reference Information

CVE: CVE-2017-4907

BID: 97914

OSVDB: 155969

VMSA: 2017-0008

IAVA: 2017-A-0128