Juniper Junos Routing Process Daemon BGP UPDATE DoS (JSA10778)

High Nessus Plugin ID 99525


The remote device is affected by a denial of service vulnerability.


According to its self-reported version and configuration, the remote Juniper Junos device is affected by a denial of service vulnerability in the routing protocol daemon (rpd) when handling a specially crafted BGP UPDATE. An unauthenticated, remote attacker can exploit this to repeatedly crash and restart the rpd daemon.

Nessus has not tested for this issue but has instead relied only on the device's self-reported version and current configuration.


Apply the relevant Junos software release or workaround referenced in Juniper advisory JSA10778.

See Also

Plugin Details

Severity: High

ID: 99525

File Name: juniper_jsa10778.nasl

Version: 1.3

Type: combined

Published: 2017/04/20

Modified: 2017/07/17

Dependencies: 55932

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/o:juniper:junos

Required KB Items: Host/Juniper/JUNOS/Version, Settings/ParanoidReport

Patch Publication Date: 2017/04/12

Vulnerability Publication Date: 2017/04/12

Reference Information

CVE: CVE-2017-2313

BID: 97606

OSVDB: 155436

JSA: JSA10778