Adobe Photoshop CC 17.x < 17.0.2 / 18.x < 18.1 PCX File Handling Arbitrary Code Execution (APSB17-12) (macOS)

High Nessus Plugin ID 99370


The remote host has an application installed that is affected by an arbitrary code execution vulnerability.


The version of Adobe Photoshop CC installed on the remote macOS or Mac OS X host is 17.x prior to 17.0.2 (2015.5.2) or 18.x prior to 18.1 (2017.1.0). It is, therefore, affected by an arbitrary code execution vulnerability due to a memory corruption issue that is triggered when handling PCX files. An unauthenticated, remote attacker can exploit this, by convincing a user to open a specially crafted PCX file, to execute arbitrary code.


Upgrade to Adobe Photoshop CC version 17.0.2 (2015.5.2) / 18.1 (2017.1.0) or later.

See Also

Plugin Details

Severity: High

ID: 99370

File Name: macosx_adobe_photoshop_apsb17-12.nasl

Version: $Revision: 1.4 $

Type: local

Agent: macosx

Published: 2017/04/14

Modified: 2017/11/16

Dependencies: 62220

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:photoshop_cc

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Photoshop

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/04/11

Vulnerability Publication Date: 2016/12/02

Reference Information

CVE: CVE-2017-3004

BID: 97559

OSVDB: 155274