Apache Tomcat 9.0.0.M11 < 9.0.0.M17 nextRequest Information Disclosure

Medium Nessus Plugin ID 99362


The remote Apache Tomcat server is affected by an information disclosure vulnerability.


The version of Apache Tomcat installed on the remote host is 9.0.0.M11 or later but prior to 9.0.0.M17. It is, therefore, affected by an information disclosure vulnerability in the nextRequest() function in Http11InputBuffer.java due to improper limits of a ByteBuffer being set. An unauthenticated, remote attacker can exploit this to disclose ByteBuffer data associated with a different request.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 9.0.0.M17 or later.

Note that the vulnerability was also fixed in version 9.0.0.M16;
however, this version was never publicly released.

See Also


Plugin Details

Severity: Medium

ID: 99362

File Name: tomcat_9_0_0_M17.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2017/04/13

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/01/16

Vulnerability Publication Date: 2017/03/13

Reference Information

CVE: CVE-2016-8747

BID: 96895

OSVDB: 153593