Samba 4.4.x < 4.4.12 / 4.5.x < 4.5.7 / 4.6.x < 4.6.1 Path Renaming Symlink Local File Disclosure

Low Nessus Plugin ID 99199

Synopsis

The remote Samba server is affected by an information disclosure vulnerability.

Description

The version of Samba running on the remote host is 4.4.x prior to 4.4.12, 4.5.x prior to 4.5.7, or 4.6.x prior to 4.6.1. It is, therefore, affected by an information disclosure vulnerability due to a race condition between calls to lstat() for symlink checks and calls to open() to read a file. A local attacker can exploit this, by replacing a recently checked path with a symlink, to disclose arbitrary files on the system.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Samba version 4.4.12 / 4.5.7 / 4.6.1 or later.
Alternatively, apply the patch or workaround referenced in the vendor advisory.

See Also

https://www.samba.org/samba/security/CVE-2017-2619.html

https://www.samba.org/samba/history/samba-4.4.12.html

https://www.samba.org/samba/history/samba-4.5.7.html

https://www.samba.org/samba/history/samba-4.6.1.html

Plugin Details

Severity: Low

ID: 99199

File Name: samba_4_6_1.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 2017/04/05

Updated: 2018/07/27

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 1.2

Temporal Score: 0.9

Vector: CVSS2#AV:L/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 2.5

Temporal Score: 2.3

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/03/23

Vulnerability Publication Date: 2017/03/23

Reference Information

CVE: CVE-2017-2619

BID: 97033