Apple iOS < 10.3.1 Wi-Fi Stack Buffer Overflow RCE

High Nessus Plugin ID 99185


The version of Apple iOS running on the mobile device is affected by a remote code execution vulnerability.


The version of Apple iOS running on the mobile device is prior to 10.3.1. It is, therefore, affected by a remote code execution vulnerability in the Wi-Fi component due to improper validation of unspecified input. An unauthenticated, remote attacker within Wi-Fi range can exploit this to cause a stack-based buffer overflow, resulting in a denial of service condition or potentially allowing the execution of arbitrary code.


Upgrade to Apple iOS version 10.3.1 or later.

See Also

Plugin Details

Severity: High

ID: 99185

File Name: apple_ios_1031_check.nbin

Version: $Revision: 1.10 $

Type: local

Published: 2017/04/04

Modified: 2018/01/29

Dependencies: 60033

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Required KB Items: mdm/dependency/unlocked

Patch Publication Date: 2017/04/03

Vulnerability Publication Date: 2017/04/03

Reference Information

CVE: CVE-2017-6975

BID: 97328

OSVDB: 154799

APPLE-SA: APPLE-SA-2017-04-03-1