VMSA-2010-0020 : VMware ESXi 4.1 Update Installer SFCB Authentication Flaw

High Nessus Plugin ID 99166


The remote VMware ESXi host is missing a security-related patch.


a. ESXi 4.1 Update Installer SFCB Authentication Flaw

Under certain conditions, the ESXi 4.1 installer that upgrades an ESXi 3.5 or ESXi 4.0 host to ESXi 4.1 incorrectly handles the SFCB authentication mode. The result is that SFCB authentication could allow login with any username and password combination.

An ESXi 4.1 host is affected if all of the following apply :
- ESXi 4.1 was upgraded from ESXi 3.5 or ESXi 4.0.
- The SFCB configuration file /etc/sfcb/sfcb.cfg was modified prior to the upgrade.
- The sfcbd daemon is running (sfcbd runs by default).

Workaround A workaround that can be applied to ESXi 4.1 is described in VMware Knowledge Base Article KB 1031761

The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2010-4573 to this issue.


Apply the missing patch.

See Also


Plugin Details

Severity: High

ID: 99166

File Name: vmware_VMSA-2010-0020.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/04/03

Modified: 2017/04/03

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:W/RC:C

Vulnerability Information

CPE: cpe:/o:vmware:esxi:4.1

Required KB Items: Host/local_checks_enabled, Host/VMware/release, Host/VMware/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/12/21

Reference Information

CVE: CVE-2010-4573

BID: 45543

OSVDB: 70114

VMSA: 2010-0020