VMware Workstation 12.x < 12.5.5 Multiple Vulnerabilities (VMSA-2017-0006) (Linux)

High Nessus Plugin ID 99104

Synopsis

A virtualization application installed on the remote Linux host is affected by multiple vulnerabilities.

Description

The version of VMware Workstation installed on the remote Linux host is 12.x prior to 12.5.5. It is, therefore, affected by multiple vulnerabilities :

- A heap buffer overflow condition exists due to improper validation of certain input. An attacker on the guest can exploit this to cause a denial of service condition or the execution of arbitrary code on the host.
(CVE-2017-4902)

- A stack memory initialization flaw exists that allows an attacker on the guest to execute arbitrary code on the host. (CVE-2017-4903)

- An unspecified flaw exists in memory initialization that allows an attacker on the guest to execute arbitrary code on the host. (CVE-2017-4904)

- An unspecified flaw exists in memory initialization that allows the disclosure of sensitive information.
(CVE-2017-4905)

Solution

Upgrade to VMware Workstation version 12.5.5 or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2017-0006.html

Plugin Details

Severity: High

ID: 99104

File Name: vmware_workstation_linux_vmsa_2017_0006.nasl

Version: $Revision: 1.4 $

Type: local

Family: General

Published: 2017/03/30

Modified: 2017/08/16

Dependencies: 71053

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 9.6

Temporal Score: 8.8

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: Host/VMware Workstation/Version, Settings/ParanoidReport

Excluded KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/03/28

Vulnerability Publication Date: 2017/03/17

Reference Information

CVE: CVE-2017-4902, CVE-2017-4903, CVE-2017-4904, CVE-2017-4905

BID: 97160, 97163, 97164, 97165

VMSA: 2017-0006