Oracle Linux 6 : curl (ELSA-2017-0847)

Medium Nessus Plugin ID 99075


The remote Oracle Linux host is missing one or more security updates.


From Red Hat Security Advisory 2017:0847 :

An update for curl is now available for Red Hat Enterprise Linux 6.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The curl packages provide the libcurl library and the curl utility for downloading files from servers using various protocols, including HTTP, FTP, and LDAP.

Security Fix(es) :

* It was found that the fix for CVE-2015-3148 in curl was incomplete.
An application using libcurl with HTTP Negotiate authentication could incorrectly re-use credentials for subsequent requests to the same server. (CVE-2017-2628)

This issue was discovered by Paulo Andrade (Red Hat).


Update the affected curl packages.

See Also

Plugin Details

Severity: Medium

ID: 99075

File Name: oraclelinux_ELSA-2017-0847.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2017/03/30

Modified: 2017/08/15

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:curl, p-cpe:/a:oracle:linux:libcurl, p-cpe:/a:oracle:linux:libcurl-devel, cpe:/o:oracle:linux:6

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/03/29

Reference Information

CVE: CVE-2017-2628

OSVDB: 154631

RHSA: 2017:0847