ImageMagick 6.x < 6.9.7-5 / 7.x < 7.0.4-5 tga.c WriteTGAImage() Assertion Failure DoS

Medium Nessus Plugin ID 97891


An application installed on the remote Windows host is affected by a denial of service vulnerability.


The version of ImageMagick installed on the remote Windows host is 6.x prior to 6.9.7-5 or 7.x prior to 7.0.4-5. It is, therefore, affected by a denial of service vulnerability in the WriteTGAImage() function in coders/tga.c due to improper handling of TGA files. An unauthenticated, remote attacker can exploit this, by convincing a user to convert a specially crafted image to a TGA file, to cause a denial of service condition.


Upgrade to ImageMagick version 6.9.7-5 / 7.0.4-5 or later. Note that you may also need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: Medium

ID: 97891

File Name: imagemagick_7_0_4_5.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2017/03/22

Modified: 2017/03/24

Dependencies: 38949

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/01/21

Vulnerability Publication Date: 2017/01/20

Reference Information

CVE: CVE-2017-6498

BID: 96591

OSVDB: 152955