IBM Integration Bus 8.x < / 9.x < / 10.x < SOAP FLOWS XXE DoS

High Nessus Plugin ID 97578


An enterprise service bus application installed on the remote host is affected by a denial of service vulnerability.


The version of IBM Integration Bus (formerly known as IBM WebSphere Message Broker) is 8.x prior to, 9.x prior to, or 10.x prior to It is, therefore, affected by a denial of service vulnerability due to an XML external entity (XXE) injection error in SOAP FLOWS when processing XML data. An unauthenticated, remote attacker can exploit this to disclose sensitive information or cause a denial of service condition.


Upgrade to IBM Integration Bus version / / or later.

See Also

Plugin Details

Severity: High

ID: 97578

File Name: ibm_integration_bus_swg21997918.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2017/03/07

Modified: 2017/07/13

Dependencies: 97579

Risk Information

Risk Factor: High


Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:/a:ibm:websphere_message_broker, cpe:/a:ibm:integration_bus

Required KB Items: installed_sw/IBM Integration Bus

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/02/10

Vulnerability Publication Date: 2016/11/21

Reference Information

CVE: CVE-2016-9706

BID: 96274

OSVDB: 148474