Splunk Enterprise 6.4.x < 6.4.6 Stored XSS Vulnerability

medium Nessus Plugin ID 97526


An application running on the remote web server is affected by a stored cross-site scripting vulnerability.


According to its self-reported version number, the version of Splunk Enterprise hosted on the remote web server is 6.4.x prior to 6.4.6. It is, therefore, affected by a stored cross-site scripting (XSS) vulnerability due to improper validation of input before returning it to users. An authenticated, remote attacker who has administrative access can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.


Upgrade Splunk Enterprise to version 6.4.6 or later.

See Also


Plugin Details

Severity: Medium

ID: 97526

File Name: splunk_646.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 3/3/2017

Updated: 11/13/2019

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Low

Base Score: 3.5

Temporal Score: 3

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2017-12572


Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/23/2017

Vulnerability Publication Date: 2/23/2017

Reference Information

CVE: CVE-2017-12572