F5 Networks BIG-IP : libarchive vulnerability (K52697522)

Medium Nessus Plugin ID 97362

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

The read_Header function in archive_read_support_format_7zip.c in libarchive 3.2.1 allows remote attackers to cause a denial of service (out-of-bounds read) via multiple EmptyStream attributes in a header in a 7zip archive. (CVE-2016-8689)

Solution

Upgrade to one of the non-vulnerable versions listed in the F5 Solution K52697522.

See Also

https://support.f5.com/csp/article/K52697522

Plugin Details

Severity: Medium

ID: 97362

File Name: f5_bigip_SOL52697522.nasl

Version: 3.10

Type: local

Published: 2017/02/24

Updated: 2019/07/17

Dependencies: 76940

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:f5:big-ip_access_policy_manager, cpe:/a:f5:big-ip_advanced_firewall_manager, cpe:/a:f5:big-ip_application_acceleration_manager, cpe:/a:f5:big-ip_application_security_manager, cpe:/a:f5:big-ip_application_visibility_and_reporting, cpe:/a:f5:big-ip_link_controller, cpe:/a:f5:big-ip_local_traffic_manager, cpe:/a:f5:big-ip_policy_enforcement_manager, cpe:/h:f5:big-ip

Required KB Items: Host/local_checks_enabled, Host/BIG-IP/hotfix, Host/BIG-IP/modules, Host/BIG-IP/version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/02/23

Vulnerability Publication Date: 2017/02/15

Reference Information

CVE: CVE-2016-8689