OpenSSL 1.1.0 < 1.1.0e Encrypt-Then-Mac Extension DoS

high Nessus Plugin ID 97328
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A service running on the remote host is affected by a denial of service vulnerability.


According to its banner, the version of OpenSSL running on the remote host is 1.1.0 prior to 1.1.0e. It is, therefore, affected by a denial of service vulnerability that is triggered during a renegotiation handshake in which the Encrypt-Then-Mac extension is negotiated when it was not in the original handshake or vice-versa. An unauthenticated, remote attacker can exploit this issue to cause OpenSSL to crash, depending on which cipher suite is being used. Note that both clients and servers are affected.


Upgrade to OpenSSL version 1.1.0e or later.

See Also

Plugin Details

Severity: High

ID: 97328

File Name: openssl_1_1_0e.nasl

Version: 1.6

Type: remote

Family: Web Servers

Published: 2/23/2017

Updated: 11/13/2019

Dependencies: openssl_version.nasl

Risk Information

CVSS Score Source: CVE-2017-3733


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No known exploits are available

Patch Publication Date: 2/16/2017

Vulnerability Publication Date: 2/16/2017

Reference Information

CVE: CVE-2017-3733