OpenSSL 1.1.0 < 1.1.0e Encrypt-Then-Mac Extension DoS

High Nessus Plugin ID 97328


A service running on the remote host is affected by a denial of service vulnerability.


According to its banner, the version of OpenSSL running on the remote host is 1.1.0 prior to 1.1.0e. It is, therefore, affected by a denial of service vulnerability that is triggered during a renegotiation handshake in which the Encrypt-Then-Mac extension is negotiated when it was not in the original handshake or vice-versa. An unauthenticated, remote attacker can exploit this issue to cause OpenSSL to crash, depending on which cipher suite is being used. Note that both clients and servers are affected.


Upgrade to OpenSSL version 1.1.0e or later.

See Also

Plugin Details

Severity: High

ID: 97328

File Name: openssl_1_1_0e.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2017/02/23

Modified: 2017/11/09

Dependencies: 57323

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7.5

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/02/16

Vulnerability Publication Date: 2017/02/16

Reference Information

CVE: CVE-2017-3733

OSVDB: 152207