GLSA-201702-26 : Nagios: Multiple vulnerabilities

Critical Nessus Plugin ID 97269


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201702-26 (Nagios: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Nagios. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker, who either is already Nagios’s system user or belongs to Nagios’s group, could potentially escalate privileges.
In addition, a remote attacker could read or write to arbitrary files by spoofing a crafted response from the Nagios RSS feed server.
Workaround :

There is no known workaround at this time.


All Nagios users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-analyzer/nagios-core-4.2.4'

See Also

Plugin Details

Severity: Critical

ID: 97269

File Name: gentoo_GLSA-201702-26.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/02/21

Modified: 2017/02/21

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:nagios-core, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/02/21

Reference Information

CVE: CVE-2008-4796, CVE-2008-7313, CVE-2016-8641, CVE-2016-9565, CVE-2016-9566

GLSA: 201702-26

CWE: 94