Acme thttpd < 2.26 Multiple Vulnerabilities

Medium Nessus Plugin ID 97144


The remote server is affected by multiple vulnerabilities.


According to its banner, the version of Acme thttpd server running on the remote host is prior to 2.26. It is, therefore, affected by multiple vulnerabilities :

- Multiple buffer overflow conditions exist in the htpasswd utility. A local attacker can exploit these, by calling htpasswd and supplying arbitrary commands along with a username to be added to the password file, to bypass required authentication and execute arbitrary programs with elevated privileges. (CVE-2006-1078)

- A flaw exists in htpasswd that allows a local attacker to gain privileges via shell metacharacters in a command line argument, which can then be used to execute other commands. (CVE-2006-1079)

- An unspecified flaw exists that allows a local attacker to create or touch arbitrary files via a symlink attack on the start_thttpd temporary file. (CVE-2006-4248)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Acme thttpd version 2.26 or later.

See Also

Plugin Details

Severity: Medium

ID: 97144

File Name: acme_thttpd_2_26.nasl

Version: 1.5

Type: remote

Family: Web Servers

Published: 2017/02/14

Updated: 2018/11/15

Dependencies: 97145

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:acme_labs:thttpd

Required KB Items: www/thttpd

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/03/05

Vulnerability Publication Date: 2006/03/05

Reference Information

CVE: CVE-2006-1078, CVE-2006-1079, CVE-2006-4248

BID: 16972, 20891