Debian DSA-3786-1 : vim - security update

High Nessus Plugin ID 97135

Synopsis

The remote Debian host is missing a security-related update.

Description

Editor spell files passed to the vim (Vi IMproved) editor may result in an integer overflow in memory allocation and a resulting buffer overflow which potentially could result in the execution of arbitrary code or denial of service.

Solution

Upgrade the vim packages.

For the stable distribution (jessie), this problem has been fixed in version 2:7.4.488-7+deb8u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854969

https://packages.debian.org/source/jessie/vim

https://www.debian.org/security/2017/dsa-3786

Plugin Details

Severity: High

ID: 97135

File Name: debian_DSA-3786.nasl

Version: 3.7

Type: local

Agent: unix

Published: 2017/02/14

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:vim, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/02/13

Reference Information

CVE: CVE-2017-5953

DSA: 3786