GLSA-201702-05 : Lsyncd: Remote execution of arbitrary code

High Nessus Plugin ID 97111

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201702-05 (Lsyncd: Remote execution of arbitrary code)

default-rsyncssh.lua in Lsyncd performed insufficient sanitising of filenames.
Impact :

An attacker, able to control files processed by Lsyncd, could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Lsyncd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-admin/lsyncd-2.1.6'

See Also

https://security.gentoo.org/glsa/201702-05

Plugin Details

Severity: High

ID: 97111

File Name: gentoo_GLSA-201702-05.nasl

Version: Revision: 3.1

Type: local

Published: 2017/02/13

Updated: 2017/02/13

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:lsyncd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/02/10

Reference Information

CVE: CVE-2014-8990

GLSA: 201702-05