EMC Documentum D2 4.5.x and 4.6.x < 4.7 Multiple Vulnerabilities (ESA-2016-167)
Medium Nessus Plugin ID 96961
SynopsisThe remote host is affected by multiple vulnerabilities.
DescriptionThe remote host is running a version of EMC Documentum D2 that is 4.5.x or 4.6.x prior to 4.7. It is, therefore, affected by multiple vulnerabilities :
- A cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-9872)
- A Document Query Language (DQL) injection vulnerability exists due to a failure to properly sanitize user-supplied input. An authenticated, remote attacker can exploit this to inject or manipulate DQL queries in the back-end database, resulting in the manipulation or disclosure of arbitrary data. (CVE-2016-9873)
SolutionUpgrade to EMC Documentum D2 version 4.7 or later. Alternatively, note that EMC has released 4.5.0200 (4.5 patch 20) and 4.6.0080 (4.6 patch 08) to resolve CVE-2016-9872.