EMC Documentum D2 4.5.x and 4.6.x < 4.7 Multiple Vulnerabilities (ESA-2016-167)

Medium Nessus Plugin ID 96961


The remote host is affected by multiple vulnerabilities.


The remote host is running a version of EMC Documentum D2 that is 4.5.x or 4.6.x prior to 4.7. It is, therefore, affected by multiple vulnerabilities :

- A cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-9872)

- A Document Query Language (DQL) injection vulnerability exists due to a failure to properly sanitize user-supplied input. An authenticated, remote attacker can exploit this to inject or manipulate DQL queries in the back-end database, resulting in the manipulation or disclosure of arbitrary data. (CVE-2016-9873)


Upgrade to EMC Documentum D2 version 4.7 or later. Alternatively, note that EMC has released 4.5.0200 (4.5 patch 20) and 4.6.0080 (4.6 patch 08) to resolve CVE-2016-9872.

See Also


Plugin Details

Severity: Medium

ID: 96961

File Name: emc_documentum_d2_ESA-2016-167.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2017/02/02

Modified: 2017/02/06

Dependencies: 77303

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.4

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:emc:documentum_d2

Required KB Items: installed_sw/EMC Documentum D2

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/01/26

Vulnerability Publication Date: 2017/01/26

Reference Information

CVE: CVE-2016-9872, CVE-2016-9873

BID: 95824, 95828

OSVDB: 151043, 151044

IAVB: 2017-B-0014