CentOS 6 / 7 : libtiff (CESA-2017:0225)

High Nessus Plugin ID 96929

Synopsis

The remote CentOS host is missing one or more security updates.

Description

An update for libtiff is now available for Red Hat Enterprise Linux 6 and Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The libtiff packages contain a library of functions for manipulating Tagged Image File Format (TIFF) files.

Security Fix(es) :

* Multiple flaws have been discovered in libtiff. A remote attacker could exploit these flaws to cause a crash or memory corruption and, possibly, execute arbitrary code by tricking an application linked against libtiff into processing specially crafted files.
(CVE-2016-9533, CVE-2016-9534, CVE-2016-9535)

* Multiple flaws have been discovered in various libtiff tools (tiff2pdf, tiffcrop, tiffcp, bmp2tiff). By tricking a user into processing a specially crafted file, a remote attacker could exploit these flaws to cause a crash or memory corruption and, possibly, execute arbitrary code with the privileges of the user running the libtiff tool. (CVE-2015-8870, CVE-2016-5652, CVE-2016-9540, CVE-2016-9537, CVE-2016-9536)

Solution

Update the affected libtiff packages.

See Also

http://www.nessus.org/u?e90f7f98

http://www.nessus.org/u?cdca795b

Plugin Details

Severity: High

ID: 96929

File Name: centos_RHSA-2017-0225.nasl

Version: 3.5

Type: local

Agent: unix

Published: 2017/02/02

Updated: 2019/10/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:centos:centos:libtiff, p-cpe:/a:centos:centos:libtiff-devel, p-cpe:/a:centos:centos:libtiff-static, p-cpe:/a:centos:centos:libtiff-tools, cpe:/o:centos:centos:6, cpe:/o:centos:centos:7

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Patch Publication Date: 2017/02/01

Vulnerability Publication Date: 2016/11/22

Reference Information

CVE: CVE-2015-8870, CVE-2016-5652, CVE-2016-9533, CVE-2016-9534, CVE-2016-9535, CVE-2016-9536, CVE-2016-9537, CVE-2016-9540

RHSA: 2017:0225