GLSA-201701-76 : HarfBuzz: Multiple vulnerabilities

High Nessus Plugin ID 96914


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-76 (HarfBuzz: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in HarfBuzz. Please review the CVE identifiers referenced below for details.
Impact :

Remote attackers, through the use of crafted data, could cause a Denial of Service condition or have other unspecified impacts.
Workaround :

There is no known workaround at this time.


All HarfBuzz users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/harfbuzz-1.0.6'

See Also

Plugin Details

Severity: High

ID: 96914

File Name: gentoo_GLSA-201701-76.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/02/01

Modified: 2017/02/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 7.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:harfbuzz, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/31

Reference Information

CVE: CVE-2015-8947, CVE-2016-2052

GLSA: 201701-76