Debian DLA-811-1 : libplist security update

Medium Nessus Plugin ID 96910

Synopsis

The remote Debian host is missing a security update.

Description

The following vulnerabilities have been fixed in libplist :

CVE-2017-5209

Out of bounds read when parsing specially crafted Apple plist file

CVE-2017-5545

Heap buffer overflow via crafted Apple plist file

For Debian 7 'Wheezy', these problems have been fixed in version 1.8-1+deb7u1.

We recommend that you upgrade your libplist packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2017/01/msg00048.html

https://packages.debian.org/source/wheezy/libplist

Plugin Details

Severity: Medium

ID: 96910

File Name: debian_DLA-811.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2017/02/01

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libplist++-dev, p-cpe:/a:debian:debian_linux:libplist++1, p-cpe:/a:debian:debian_linux:libplist-dbg, p-cpe:/a:debian:debian_linux:libplist-dev, p-cpe:/a:debian:debian_linux:libplist-doc, p-cpe:/a:debian:debian_linux:libplist-utils, p-cpe:/a:debian:debian_linux:libplist1, p-cpe:/a:debian:debian_linux:python-plist, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/01/31

Reference Information

CVE: CVE-2017-5209, CVE-2017-5545