GLSA-201701-70 : Firewalld: Improper authentication methods

Low Nessus Plugin ID 96856


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-70 (Firewalld: Improper authentication methods)

A flaw in Firewalld allows any locally logged in user to tamper with or change firewall settings. This is due to how Firewalld handles authentication via polkit which is not properly applied to 5 particular functions to include: addPassthrough, removePassthrough, addEntry, removeEntry, and setEntries.
Impact :

A local attacker could tamper or change firewall settings leading to the additional exposure of systems to include unauthorized remote access.
Workaround :

There is no known workaround at this time.


All Firewalld users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-firewall/firewalld-'

See Also

Plugin Details

Severity: Low

ID: 96856

File Name: gentoo_GLSA-201701-70.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/01/30

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N


Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:firewalld, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/29

Reference Information

CVE: CVE-2016-5410

GLSA: 201701-70