GLSA-201701-69 : Ark: Unintended execution of scripts and executable files

Medium Nessus Plugin ID 96855


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-69 (Ark: Unintended execution of scripts and executable files)

A vulnerability was discovered in how Ark handles executable files while browsing a compressed archive. A user could unintentionally execute a malicious script which has the executable bit set inside of the archive.
This is due to Ark not displaying what files are executable and running the associated applications for the file type upon execution.
Impact :

A remote attacker, by coercing a user to browse a malicious archive file within Ark and execute certain files, could execute arbitrary code with the privileges of the user.
Workaround :

There is no known workaround at this time.


All Ark users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=kde-apps/ark-16.08.3-r1'

See Also

Plugin Details

Severity: Medium

ID: 96855

File Name: gentoo_GLSA-201701-69.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/01/30

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ark, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/29

Reference Information

CVE: CVE-2017-5330

GLSA: 201701-69