GLSA-201701-68 : FreeImage: Multiple vulnerabilities

Medium Nessus Plugin ID 96854


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-68 (FreeImage: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in in FreeImage. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker, by enticing a user to process a specially crafted image file, could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All FreeImage users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/freeimage-3.15.4-r1'

See Also

Plugin Details

Severity: Medium

ID: 96854

File Name: gentoo_GLSA-201701-68.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/30

Modified: 2017/01/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:freeimage, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/29

Reference Information

CVE: CVE-2015-0852, CVE-2016-5684

GLSA: 201701-68