Cisco WebEx Extension for Chrome RCE (cisco-sa-20170124-webex)

high Nessus Plugin ID 96772

Synopsis

A browser extension installed on the remote host is affected by a remote code execution vulnerability.

Description

The Cisco WebEx Extension for Chrome installed on the remote host is affected by a remote code execution vulnerability due to a crafted pattern that permits any URL utilizing it to automatically use native messaging to access sensitive functionality provided by the extension.
An unauthenticated, remote attacker can exploit this vulnerability to execute arbitrary code by convincing a user to visit a web page that contains this pattern and starting a WebEx session.

Solution

Upgrade to Cisco WebEx Extension version 1.0.7 or later.

See Also

http://www.nessus.org/u?068aee48

https://bugs.chromium.org/p/project-zero/issues/detail?id=1096

https://bugs.chromium.org/p/project-zero/issues/detail?id=1100

Plugin Details

Severity: High

ID: 96772

File Name: cisco_webex_extension_rce.nasl

Version: 1.10

Type: local

Agent: windows

Family: Windows

Published: 1/25/2017

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome, cpe:/a:cisco:webex

Required KB Items: SMB/Google_Chrome/Installed, SMB/WindowsVersion

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/22/2017

Vulnerability Publication Date: 1/23/2017

Exploitable With

Metasploit (Cisco WebEx Chrome Extension RCE (CVE-2017-3823))

Reference Information

CVE: CVE-2017-3823

BID: 95737