GLSA-201701-58 : ICU: Multiple vulnerabilities

High Nessus Plugin ID 96744


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-58 (ICU: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in ICU. Please review the CVE identifiers referenced below for details.
Impact :

Remote attackers could cause a Denial of Service condition or possibly have other unspecified impacts via a long locale string or httpAcceptLanguage argument. Additionally, A remote attacker, via a specially crafted file, could cause an application using ICU to parse untrusted font files resulting in a Denial of Service condition.
Finally, remote attackers could affect confidentiality via unknown vectors related to 2D.
Workaround :

There is no known workaround at this time.


All ICU users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/icu-58.1'

See Also

Plugin Details

Severity: High

ID: 96744

File Name: gentoo_GLSA-201701-58.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/25

Modified: 2017/01/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:icu, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/24

Reference Information

CVE: CVE-2015-2632, CVE-2016-6293, CVE-2016-7415

GLSA: 201701-58