HP Version Control Repository Manager for Linux < 7.6.0 Multiple Vulnerabilities

Medium Nessus Plugin ID 96722

Synopsis

An application installed on the remote Linux host is affected by multiple vulnerabilities.

Description

According to its self-reported version, the HP Version Control Repository Manager (VCRM) application installed on the remote Linux host is prior to 7.6.0. It is, therefore, affected by multiple vulnerabilities :

- A cross-site request forgery (XSRF) vulnerability exists in VCRM due to HTTP requests not requiring multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. An unauthenticated, remote attacker can exploit this, by convincing a user into following a specially crafted link, to perform unspecified actions. (CVE-2016-8513)

- An unspecified flaw exists in VCRM that allows an authenticated, remote attacker to disclose potentially sensitive information. (CVE-2016-8514)

- An unspecified flaw exists in VCRM that allows an authenticated, remote attacker to upload arbitrary files.
(CVE-2016-8515)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to HP Version Control Repository Manager version 7.6.0 or later.

See Also

http://www.nessus.org/u?b6730ba8

Plugin Details

Severity: Medium

ID: 96722

File Name: hp_version_control_repo_manager_7_6_0_nix.nasl

Version: 1.5

Type: local

Family: Misc.

Published: 2017/01/24

Updated: 2018/11/15

Dependencies: 85804

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.7

Temporal Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:hp:version_control_repository_manager

Required KB Items: installed_sw/HP Version Control Repository Manager for Linux

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/17

Vulnerability Publication Date: 2016/12/15

Reference Information

CVE: CVE-2016-8513, CVE-2016-8514, CVE-2016-8515

BID: 94949

HP: emr_na-c05356363, HPSBMU03684

IAVB: 2017-B-0025