GLSA-201701-53 : Lua: Buffer overflow

Medium Nessus Plugin ID 96688


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-53 (Lua: Buffer overflow)

A buffer overflow was discovered in the vararg functions in ldo.c in Lua.
Impact :

Context-dependent could cause a Denial of Service condition or execute arbitrary code.
Workaround :

There is no known workaround at this time.


All Lua users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/lua-5.1.5-r4'

See Also

Plugin Details

Severity: Medium

ID: 96688

File Name: gentoo_GLSA-201701-53.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/23

Modified: 2017/01/23

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:lua, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/23

Reference Information

CVE: CVE-2014-5461

GLSA: 201701-53