Debian DSA-3768-1 : openjpeg2 - security update

Medium Nessus Plugin ID 96667

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities in OpenJPEG, a JPEG 2000 image compression / decompression library, may result in denial of service or the execution of arbitrary code if a malformed JPEG 2000 file is processed.

Solution

Upgrade the openjpeg2 packages.

For the stable distribution (jessie), these problems have been fixed in version 2.1.0-2+deb8u2.

See Also

https://packages.debian.org/source/jessie/openjpeg2

https://www.debian.org/security/2017/dsa-3768

Plugin Details

Severity: Medium

ID: 96667

File Name: debian_DSA-3768.nasl

Version: 3.5

Type: local

Agent: unix

Published: 2017/01/23

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openjpeg2, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/01/20

Reference Information

CVE: CVE-2016-5159, CVE-2016-8332, CVE-2016-9572, CVE-2016-9573

DSA: 3768