GLSA-201701-38 : Pidgin: Multiple vulnerabilities

High Nessus Plugin ID 96542


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-38 (Pidgin: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Pidgin. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker might send specially crafted data using the MXit protocol, possibly resulting in the remote execution of arbitrary code with the privileges of the process, a Denial of Service condition, or in leaking confidential information.
Workaround :

There is no known workaround at this time.


All Pidgin users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-im/pidgin-2.11.0'

See Also

Plugin Details

Severity: High

ID: 96542

File Name: gentoo_GLSA-201701-38.nasl

Version: $Revision: 3.4 $

Type: local

Published: 2017/01/17

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pidgin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/17

Reference Information

CVE: CVE-2016-1000030, CVE-2016-2365, CVE-2016-2366, CVE-2016-2367, CVE-2016-2368, CVE-2016-2369, CVE-2016-2370, CVE-2016-2371, CVE-2016-2372, CVE-2016-2373, CVE-2016-2374, CVE-2016-2375, CVE-2016-2376, CVE-2016-2377, CVE-2016-2378, CVE-2016-2379, CVE-2016-2380, CVE-2016-4323

GLSA: 201701-38