ImageMagick 6.x < 6.9.7-3 ReadPSDLayers() Function PSB File Handling RCE

High Nessus Plugin ID 96446


An application installed on the remote Windows host is affected by a remote code execution vulnerability.


The version of ImageMagick installed on the remote Windows host is 6.x prior to 6.9.7-3. It is, therefore, affected by a remote code execution vulnerability in the ReadPSDLayers() function in psd.c due to improper validation of PSB files. An unauthenticated, remote attacker can exploit this, by convincing a user to open a specially crafted PSD file, to cause a denial of service condition or the execution of arbitrary code.


Upgrade to ImageMagick version 6.9.7-3 or later. Note that you may also need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: High

ID: 96446

File Name: imagemagick_6_9_7_3.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2017/01/12

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/01/07

Vulnerability Publication Date: 2017/01/07

Reference Information

OSVDB: 149784