GLSA-201701-30 : vzctl: Security bypass

Low Nessus Plugin ID 96424


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-30 (vzctl: Security bypass)

It was discovered that vzctl determined the virtual environment (VE) layout based on the presence of root.hdd/DiskDescriptor.xml in the VE private directory. This allows local simfs container (CT) root users to change the root password for arbitrary ploop containers. This is demonstrated by a symlink attack on the ploop container root.hdd file which can then be used to access a control panel.
Impact :

An attacker with root privileges, in a simfs-based container, could gain control over ploop-based containers.
Workaround :

There is no known workaround at this time.


All vzctl users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-cluster/vzctl-4.9.4'

See Also

Plugin Details

Severity: Low

ID: 96424

File Name: gentoo_GLSA-201701-30.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/12

Modified: 2017/01/12

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:vzctl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/11

Reference Information

CVE: CVE-2015-6927

GLSA: 201701-30