GLSA-201701-23 : Botan: Multiple vulnerabilities

Medium Nessus Plugin ID 96417


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-23 (Botan: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Botan. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker might obtain ECDSA secret keys via a timing side-channel attack or could possibly bypass TLS policy.
Workaround :

There is no known workaround at this time.


All Botan users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/botan-1.10.13'

See Also

Plugin Details

Severity: Medium

ID: 96417

File Name: gentoo_GLSA-201701-23.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/12

Modified: 2017/01/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:botan, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/11

Reference Information

CVE: CVE-2016-2849, CVE-2016-2850

GLSA: 201701-23