Debian DSA-3755-1 : tomcat8 - security update

Medium Nessus Plugin ID 96345

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that incorrect error handling in the NIO HTTP connector of the Tomcat servlet and JSP engine could result in information disclosure.

Solution

Upgrade the tomcat8 packages.

For the stable distribution (jessie), this problem has been fixed in version 8.0.14-1+deb8u6.

See Also

https://packages.debian.org/source/jessie/tomcat8

https://www.debian.org/security/2017/dsa-3755

Plugin Details

Severity: Medium

ID: 96345

File Name: debian_DSA-3755.nasl

Version: 3.9

Type: local

Agent: unix

Published: 2017/01/10

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:tomcat8, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/01/08

Reference Information

CVE: CVE-2016-8745

DSA: 3755