Palo Alto Networks PAN-OS Management Interface Remote DoS (PAN-SA-2016-0027)

high Nessus Plugin ID 96314
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by a denial of service vulnerability.

Description

The Palo Alto Networks PAN-OS running on the remote host is affected by a NULL pointer dereference flaw in the web management interface, specifically in the parseRange() function within file rx.c, when handling HTTP requests involving a Range header with an empty value.
An unauthenticated, remote attacker can exploit this, via a specially crafted request, to cause the Appweb process for the management interface to terminate, resulting in a denial of service condition.

Note that PAN-OS is reportedly affected by other vulnerabilities as well; however, Nessus has not tested for these.

Solution

Upgrade to Palo Alto Networks PAN-OS version 5.0.20 / 5.1.13 / 6.0.15 / 6.1.15 / 7.0.11 / 7.1.6 or later.

See Also

https://securityadvisories.paloaltonetworks.com/Home/Detail/60

Plugin Details

Severity: High

ID: 96314

File Name: palo_alto_PAN-SA-2016-0027_remote.nasl

Version: 1.4

Type: remote

Published: 1/5/2017

Updated: 11/22/2019

Dependencies: palo_alto_webui_detect.nbin

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: www/palo_alto_panos, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/31/2016

Vulnerability Publication Date: 10/31/2016

Reference Information

CVE: CVE-2014-9708

BID: 73407